Skip navigation
Welcome, Guest! Please Login or Join


Controller Won't Charge My Other One Will...

Sep 13, 2017 at 2:15:13 PM
Zero Insertion Force (1)

< Bandicoot >
Posts: 2 - Joined: 09/13/2017
I just replaced the batteries in two DS3s, both were fine for a while; now one won't charge. Tried with multiple cables, multiple USB ports, two systems (CECHB, CECHG...) Tried the reset on the controller, hit the charge port and cables with CRC electrical cleaner.

One controller always charges, the other one just flashes once and gives the "line" instead of charge indicator when it's plugged in. Since it is still charged, I can see that the battery is now at two bars when I use it unplugged, but it will shortly need to be charged again if I keep using it.

Can't seem to google any solution; is it possible the battery I replaced was faulty, although it still has voltage? I removed it again and made certain the connection was solid to be sure, but can't find anything obviously wrong and it still doesn't work.

PSA: Keep your slots super-loose!